ג'ומלה 3.1.0 - תגיות בפניםפרויקט ג'ומלה גאה להכריז על זמינותה המיידי של ג'ומלה 3.1.0. גרסה זו הינה גרסת אבטחה המכילה בנוסף תיקוני באגים.
מטרת צוות גרעין הפיתוח הוא להמשיך ולספק עדכונים תקופתיים עבור קהילת ג'ומלה. למדו עוד על פיתוח ג'ומלה באתר המפתחים.

הורדה

שימו לב

  • אנא קראו את הוראות העדכון מגירסה 3.0.0  (אנגלית) לפני עדכון.
  • במקרה שאתם לא יכולים לשדרג לגירסה 3.1, ישנו שדרוג לגירסה 3.0.4 המתקנת מספר בעיות אבטחה בגירסה 3.0.3 וניתן להורידה מכאן - ג'ומלה 3.0.4. בכל אופן, התמיכה בגירסה 3.0 תיפסק בעוד כחודש ועליכם לוודא שדרוג לגירסה 3.1 בקרוב.

הוראות

אנא שימו לב כי עליכם לגבות תמיד לפני תחילת שדרוג אתרכם.

מהם הפיצ'רים החדשים בגירסה 3.1

להלן התכונות החדשות בגירסה זו - 3.1:

  • תגים - אפשרות להוספת תגיות בצורה נוחה ולאפשר למפתחי הרחבות צד שלישי להשתמש בהם. עוד ניתן לקרוא כאן.
  • ניתן לראות לוגים במצב ניטור (דיבאג).
  • בנייה מחדש (רפקטורינג) של ההתקנה כדי לעשות שימוש במודל ה-MVC החדש.
  • הוספת עימוד (pagination) בתוצאות החיפוש.
  • הוספת טריגרים בעת שמירה של קונפיגורציה כדי לאפשר למפתחים להרחיב את ההגדרות בקלות.
  • טעינת קובץ שפה עבור פלאגינים באופן אוטומטי.
  • הוספת תמיכה ב-SQL Server עבור האינדקסר.
  • הוספת חבילת מדיה ויקי.
  • הוספת חבילה של OpenStreetMap.
  • הוספת תמיכה בשאילתות UNION.
  • הסרת הפלאגין GeSHi.

מה חדש בג'ומלה 3?

  • שימוש ב-Bootstrap של טוויטר ובחבילת המדיה jui.
  • תבנית ניהול חדשה ורספונסיבית, ששמה Isis, הכוללת מראה חדש.
  • תבנית צד קדמי חדשה, ששמה Protostar, הנבנתה של ה-Bootstrap של טוויטר.
  • תבנית צד קדמי חדשה ורספונסיבית ששמה Beez3.
  • דרייבר עבור PostgreSQL. תוכלו להריץ אתרי ג'ומלה 3.0 בעזרת שימוש בבסיס הנתונים PostgreSQL.
  • שכבת מטמון Memcached (גילוי נאות: מתרגם המאמר תרם פיצ'ר זה).
  • שימוש ב-JFeed עבור ניהול פידים במקום SimplePie.
  • התקנת חבילות שפה ישירות מניהול הרחבות.
  • קבוצת ACL חדשה Guest כברירת מחדל.
  • שמירת מאמרים ריקים אפשרית.
  • מודול סטטיסיטיקות חדש בניהול.
  • עדכון TinyMCE לגירסה 3.5.6.
  • המשך ניקוי קוד, קבצים, שדות וטבלאות בבסיס נתונים שאינם בשימוש.
  • שיפור סטנדרטים של טבלאות.
  • שיפורים בחיפוש החכם.
  • סטנדרטיזציה של קוד.
  • בדיקות יחידה (Unit Testing) של ה-CMS.
  • עדכון בדיקות מערכת ב-CMS.

בנוסף לכל אלה, עודכנה הפלטרפורמה של ג'ומלה (ליבת ג'ומלה המופרדת מה-CMS) לגירסה חדשה והיא כוללת חבילות חדשות.

כיצד אוכל לעדכן מג'ומלה 3.0 לג'ומלה 3.1?

השדרוג מתבצע בלחיצת כפתור מהניהול של ג'ומלה עם תאימות לאחור מלאה.

מה קורה עם ג'ומלה 2.5?

גירסה 2.5 הינה גירסה עם תמיכה ארוכת טווח (LTS) ותיתמך לפחות עד לאחר שחרור גירסה 3.5 שתצא באביב 2014. משתמשים אינם נדרשים לשדרג לג'ומלה 3.0 או 3.1.

האם אפשרי לעדכן ישירות לג'ומלה 3?

מעבר לג'ומלה 3 מג'ומלה 2.5 תהיה מיגרציה ולא שדרוג, למרות שעבור הליבה של ג'ומלה המיגרציה עשוייה להיות פשוטה. אף-על-פי-כן, קרוב לוודאי שתבניות עבור ג'ומלה 2.5 יצטרכו להתעדכן כדי שהן יעבדו עם ג'ומלה 3 וקרוב לוודאי שגם הרבה הרחבות. כמו תמיד, בדיקות לפני מיגרציה והתייעצו עם מפתחי הרחבות ותבניות שהנכם משתמשים.

מה קורה עם ג'ומלה 1.5?

התמיכה בג'ומלה 1.5 הסתיימה באופן רשמי באפריל 2012 ואנו המשכנו את התמיכה לא בצורה רשמית עד סוף 2012.

האם המשמעות של זה שאתרי ג'ומלה 1.5 הפסיקו או יפסיקו לפעול? לא (!), אתריכם ימשיכו לעבוד כמו תמיד. אף-על-פי-כן, מפתחי ג'ומלה לא ישחררו גירסאות נוספות בסדרה זו (1.5), ועקב זאת לא ישוחררו תיקוני אבטחה. בגלל סיבה זו מומלץ להמיר את אתריכם לגירסה 2.5.

מעבר מג'ומלה 2.5 ל-3 הינו יחסי קל, מכיוון שג'ומלה הפכה את התהליך לפשוט החל מהגירסאות החדשות. לצערינו, מעבר מג'ומלה 1.5 אינו צעד פשוט. לשמחתנו ישנן שתי הרחבות טובות שעושות את התהליך פשוט: jUpgrade או SPUpgrade.

יש לכם אפשרות לעבור ישירות לג'ומלה 3 או לעבור קודם לגירסה 2.5. שני הרכיבים מסוגלים להמיר לשני הגירסאות. אנא בדקו את התיעוד שלהם לשדרוג ל2.5/3.0.

ראו גם

 

עליך להירשם כדי להוסיף תגובות

עופר כהן

חובב ג'ומלה
אתר המחבר/ת: http://embad.com