במידה ולא שמעתם, ג'ומלה 1.7 שוחררה ב-19 ביולי 2011. זוהי הגירסה הראשונה של ג'ומלה במחזורי שחרור של 6 חודשים.

1. האם עליכם לעדכן את ג'ומלה 1.6 לג'ומלה 1.7?

לחלוטין עליכם לשדרג. ליתר דיוק, אתם חייבים. ג'ומלה 1.6 תגיע לסיום מחזור החיים שלה באוגוסט 2011, רק בעוד מספר שבועות. לאחר מכן, ג'ומלה 1.6 לא תקבל עדכוני אבטחה, משמע שאם תתגלה בעיית אבטחה, היא לא תתוקן. המשמעות של זה שאם האתר שלכם נפרץ מפרצה ב-1.6, לא תהיה לכם ברירה אחרת מאשר לשדרג ל-1.7 בכל מקרה. לכן, עליכם להעביר את אתרכם מוקדם מאשר במאוחר. 
אה, ושדרוג מ-1.6 ל-1.7 הוא מאוד פשוט, באמצעות שדרוג בלחיצת כפתור.

2. האם הג'ומלה 1.6 שלי תמשיך לרוץ גם אם לא אשדרג?

כן, אם לא תשדרג את אתרכם, האתר שלכם ימשיך לרוץ... לעת עתה.ראו את נושא עדכוני האבטחה לעיל.

בוני הרחבות יבנו עבור גירסת ג'ומלה הנוכחית, אז אם תרצו להוסיף הרחבה נוספת לאתר ג'ומלה 1.6, או שתרצו לשנות תבנית, תמצאו קושי לעשות זאת.

3. כיצד אני משדרג מ-1.6 ל-1.7?

ראשית, אם אתם מריצים ג'ומלה 1.6, וודאו שאתם מריצים את גירסה 1.6.5. האחרונה שוחררה בסוף יוני, רק בעזרת גירסה זו והגירסאות אחריה מאפשרות לעבור ל-1.7.

לחצו כאן עבור הוראות שדרוג.

4. האם הרחבות ותבניות ג'ומלה 1.6 מתאימות לג'ומלה 1.7?

נאמר לנו שכל ההרחבות שהן תואמות ל-1.6 אמורות לא לעשות בעיות בג'ומלה 1.7. כמו תמיד, תרצו לבדוק זאת קודם. אנחנו ממליצים בחום ליצור עותק של אתרך, לשדרג אותו ל-1.7 ולבדוק את כל האתר כדי לוודא שהכל עובד בסדר, כולל הרחבות צד שלישי.

תבניות אמורות להיות תואמות בין מעבר גירסאות.

5. מהן התכונות והפונקציונליות החדשות בג'ומלה 1.7?

האנשים שהביאו לכם את ג'ומלה 1.6, לאחר 3 שנות עבודה על הפרויקט, הביאו לכם את ג'ומלה 1.7 ב-6 חודשים. כמובן, גירסה זו לא מכילה את אותה כמות התכונות, מכיוון שהיה הרבה פחות זמן פיתוח בגירסה זו.

מנקודת מבט של בוני אתרים, ישנם שיפורים קטנים, כמו היכולת להוסיף תמונת רקע למודול HTML מותאם אישית, היכולת להגדיר את שם האתר לפני או אחרי כותרת העמוד וכפתור "הסר תיקיית התקנה" כחלק מתהליך ההתקנה. אל תחפש עבור שינויים גדולים כמו תבנית מנהל חדשה

מנקודת מבט של מפתח, השינויים הם יותר משמעותיים. ליבת ג'ומלה (Joomla Framework) הופרדה ממערכת ניהול התוכן (CMS), משמע שאפשר לבנות אפליקציות חדשות עם ליבת ג'ומלה (ראה גם במאמר מתוך המגזין העולמי של ג'ומלה). כמו כן, היו 300 תיקוני באגים בגירסה זו.

6. האם עלי לשדרג את ג'ומלה 1.5 לג'ומלה 1.7?

כמו תמיד, התשובה היא "זה תלוי". בכל אופן, אם אתר ג'ומלה 1.5 עובד טוב, לא הייתי מעביר אותו עדיין. ג'ומלה 1.5 תמשיך להיתמך עד אפריל 2012. ג'ומלה 1.8 תשוחרר בינואר 2012, והיא גירסה בעלת תמיכת ארוכת טווח (מכונה LTS), משמע שהיא תיתמך 18 חודשים לאחר מכן במקום 6 חודשים.

7. אני בונה אתר חדש, האם עלי לבנות ב-1.5 או ב-1.7?

בנקודת זמן זו, תצטרכו בהחלט להעביר את אתרך לג'ומלה 1.8 בעוד כשש חודשים, בין אם זה ג'ומלה 1.5 או 1.7. אף-על-פי-כן, המעבר מ-1.7 ל-1.8 יהיה פחות כואב מאשר המעבר מ-1.5 ל-1.7. פחות כואב משמע פחות עלות, משמע שמנקודת מבט של לקוח, בניה ב-1.7 תהיה יותר הגיונית.

אם אתם צריכים הרחבות שעדיין לא מותאמות ל-1.6 או 1.7 (K2 עדיין בבטא עבור 1.6, ומרבית עגלות הקניות הגדולות, כמו redSHOP (שימו לב כי לרכיב redShop שוחררה ב-1 לספטמבר גירסה המותאמת ל-1.7), VirtueMart, ו-Tienda עדיין מותאמות רק ל-1.5), תצטרך לבנות את אתרך ב-1.5 לעת עתה.

 

לחץ כאן לשאול שאלות אודות תהליך השדרוג בפורום ג'ומלה ישראל.

תורגם מאנגלית מתוך האתר העולמי.


עליך להירשם כדי להוסיף תגובות

עופר כהן

חובב ג'ומלה
אתר המחבר/ת: http://embad.com